Default routing (not on blueprint)
General information on “Default routing”:
- A default route is a route, where all traffic not matching any other, more specific prefix, goes to
- IPv4 default route: 0.0.0.0/0
- IPv6 default route: ::/0
Static default doute
General information on “Static default route”:
- The target of the default route should be the next-hop IP address (exit-interface only is possible but not recommended)
- If the next-hop is an IPv6 link-local address, then a exit-interface is mandatory
- By default, the AD for a statically configured route is 1 but can be changed
“Static default route” CLI configuration commands:
## Configuring a static IPv4 default route
Router(config-router)# ip route 0.0.0.0 0.0.0.0 [<next-hop-ip> | <exit-if>] [<ad>]
## Configuring a static IPv6 default route
Router(config-router)# ipv6 route ::/0 [<next-hop-ip> | <exit-if>] [<ad>]
EIGRP default route
In EIGRP there are two ways:
- Static route + redistribution/network command:
- Configure a static default route
- Inject the route via redistribution (IPv4 + IPv6) or the network command (IPv4 only)
- Summary-address:
- In EIGRP classic mode: Configured on the interface running EIGRP
- In EIGRP named mode: Configured under the af-interface within the EIGRP process
“EIGRP default route” CLI configuration commands:
## Configuring an EIGRP default route using redistribution (classic mode)
Router(config)# ip route 0.0.0.0 0.0.0.0 [<next-hop-ip> | <exit-if>] [<ad>]
Router(config-router)# redistribute static metric [metric parameters]
## Configuring an EIGRP default route using the network command (classic mode)
Router(config)# ip route 0.0.0.0 0.0.0.0 [<next-hop-ip> | <exit-if>] [<ad>]
Router(config-router)# network 0.0.0.0 0.0.0.0
## Configuring an EIGRP default route using redistribution (named mode)
Router(config)# ip route 0.0.0.0 0.0.0.0 [<next-hop-ip> | <exit-if>] [<ad>]
Router(config-router-af-topology)# redistribute static metric [metric parameters]
## Configuring an EIGRP default route using the network command (named mode)
Router(config)# ip route 0.0.0.0 0.0.0.0 [<next-hop-ip> | <exit-if>] [<ad>]
Router(config-router-af-topology)# network 0.0.0.0 0.0.0.0
## Configuring an EIGRP default route using the summary-address (classic mode)
Router(config-if)# ip summary-address eigrp <asn> 0.0.0.0 0.0.0.0
## Configuring an EIGRP default route using the summary-address (named mode)
Router(config-router-af-interface)# summary-address 0.0.0.0 0.0.0.0
OSPF default route
General information about “OSPF default route”:
- Default Route injection is done on ASBRs
- The route will be injected as E2 route (Type 5 LSA)
- Without additional parameters, the route must exist in the routing table already
- If the parameter always is used, it will be advertised even if it doesn’t exist yet
- Unlike in EIGRP, it’s not possible to redistribute a default route
- Important: Within an NSSA a different command must be used to inject the default route as a Type 7 LSA!
## Injecting an OSPF default route within normal areas
Router(config)# router ospf <pid>
Router(config-router)# default-information-originate [always | metric | metric-type | route-map]
## Injecting an OSPF default route within a NSSA
Router(config)# router ospf <pid>
Router(config-router)# area <id> nssa default-information-originate [metric | metric-type | route-map | nssa-only | ...]
BGP default route
In BGP there are three ways:
- Using the network command:
- The default route must be in the routing table
- Can be configured globally
- Using redistribution:
- The default route must be in the routing table and learned by the protocol redistributing from
- Can be configured globally
- Using unconditional origination:
- The default route must not be in the routing table
- Can be configured on a per-neighbor basis
“BGP default route” CLI configuration commands:
## Configuring a BGP default route using the network command
Router(config)# router bgp <asn>
Router(config-router)# address-family [ipv4 | ipv6 | vpnv4 | ...]
Router(config-router-af)# network 0.0.0.0
## Configuring a BGP default route using redistribution
Router(config)# router bgp <asn>
Router(config-router)# address-family [ipv4 | ipv6 | vpnv4 | ...]
Router(config-router-af)# redistribute <protocol>
Router(config-router-af)# default-information originate
## Configuring an unconditional BGP default route on a per-neighbor basis
Router(config)# router bgp <asn>
Router(config-router)# address-family [ipv4 | ipv6 | vpnv4 | ...]
Router(config-router-af)# neighbor <ip> default-originate